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Abstract
The computer vision system based application growths are
very many needs to gather the information in the unusual
environment. Surveillance systems are using in many
applications. To get better surveillance system, object
detection and recognition techniques need to discuss. In this
field, object recognition has gained lots of attraction for realtime application. Various techniques have proposed for
recognizing and detecting the object from the picture. In the
proposed article, R-CNN techniques are presenting for object
recognition in the unusual environment. This technique gets
reduce the complexity to detect the object from complex
scenarios.
Keyword: Image classification, object detection, convolution
neural network, deep-learning.

INTRODUCTION
Computer Vision Techniques have proven as a promising
technology for real-time applications such as the surveillance
system, medical imaging. In real-time applications like video
surveillance system, various occlusions and objects affect the
do in surveillance system. The technique of object detection is
a promising and challenging technique to apply in the field.
Object detection technique is to find the objects in any real
time from natural scene images such as the face, dog and
building. These are presenting then these objects are detecting
by using object detection scheme. Object detection techniques
perform the desired operation with the help of feature
extraction technique and feature learning scheme. Each object
belongs to the different object class which known as object
classification and carried out with the help of classification
techniques. Classification is a process to find the category of
the detected object in any image. Each object or each class of
the object has its own features and characteristics responsible
to make be difference in each class. This technique helps to
recognize and classify the objects from any input image.
Object recognition techniques are using in various real-time
applications such as image retrieval, surveillance, security,
vehicle tracking and parking systems. Various challenges are
presenting in this field of object recognition. The challenging
issue is considering about the robustness of the object
recognition system. This technique is using for various realtime applications where guaranteed performance is demand,
this performance is degrade due to image scale variation, the
different viewpoint, deformations and imaging conditions of
image acquisition. Another issue is cause due to the huge

amount of data in the every object class which causes conflict
resulting in performance degradation.

LITERATURE REVIEW
Various techniques have been proposed for object detection
recently such as frame difference based method [1][2], optical
flow computation [3], point detectors [4], temporal difference
method [5], background subtraction techniques [6].
Frame differencing method [2] is applied to video sequence to
detect the objects. This method computes the difference
between two consecutive frames or images and detects an
object. This method shows good performance even if
computation environment is dynamic in nature. This method
suffers from the issue of a complete outline of the moving
object which results in performance degradation of object
detection. Optical flow [3] based computation method which
depends on the computation of optical flow and image
clustering. This method is capable to provide information
regarding movement of each object present in the image.
Compare to background subtraction [6] based method, this
method provides 85% better accuracy for object detection.
The typical challenges of background subtraction in the
context of video surveillance have such as, Illumination
Changes, Dynamic Background, Occlusion, Clutter,
Camouflage, Presence of Shadows, Motion of the Camera,
Bootstrapping, Video Noise, and Speed of the Moving
Objects, Intermittent Object Motion and Challenging Weather.
Point detector is also used for object detection in computer
vision system based applications. This is a technique which
extracts the key points from the image considering texture and
location information of the image. This approach provides
better results where illumination and camera viewpoints are
varying frequently. In this field, Harris detector [7], KLT
detector method [8] and SIFT detector [9]. The temporal
difference method for detecting the object and Working
process of this method is similar to the frame differencing
method.
The pixel-wise difference of two-or-three frames is computed
resulting in the extraction of moving region from input image
sequence. If moving object [10][11] consists of uniform
texture pattern then this approach results in better adaptability
considering dynamic scene change for object detection. The
key challenge in this technique includes various aspects such
as computational complexity and noise-sensitivity which
makes it more complex to implement for real-time
applications. Object recognition technique based on the
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feature extraction method using linear SVM technique [12].
A new approach for object recognition using deep convolution
neural network, named as ConvNet or CNN to obtain higher
and faster rate of object detection [13]. Initially, image
integral is obtained which helps to improve the computation
time [14].
Object detection performance [16] depends upon the training
process of the feature set and feature extraction technique.
Variation in domain shift factors, spatial location performance
and image qualities are the main components which are
responsible for object detection performance in video or
image datasets.
Object detection [17] by considering background subtraction
as a benchmark technique for fixed camera view scenarios.
However, various components are present which affect the
performance of object recognition or detection. These
components [15] are illumination variation, shadow casting,
background movement and camera vibration etc. studies
regarding background subtraction technique to improve the
accuracy of object detection model.
The method [18] mitigates the performance issue of existing
saliency detection method. Salient region extraction is
performed by taking existing saliency detection technique
along with distance weighting, binarization and morphological
methods. Later, superpixel segmentation model is applied
where the Bayesian model is used for saliency refinement
resulting accurate saliency mapping.
An iterative
optimization method is designed to obtain better saliency
results by exploiting the characteristics of the output saliency
map each time. Through the iterative optimization process, the
rough saliency map is updated step by step with better and
better performance until an optimal saliency map is obtained.
Object detection [19] by extending the hierarchical model
resulting in sequential frame updating considering dynamic
scenes. The method utilizes dictionary learning based scheme
developed using two-layer model. The model is developed
using three-stage modelling for improving the sparse
representation resulting in significant improvement in object
detection and classification.
Feature extraction based model [20] also utilizes saliency
technique as a base model. Hybrid feature modelling used to
improve the detection performance. Since images are diverse
nature which shows that images have different context
significant nature. In order to deal with diversity, here a
feature detector model is developed by introducing feature
quality measurement. This approach shows significant
performance as tested with benchmark datasets. The saliencybased technique is developed [21] which is named as Deep
Saliency. Object detection performance also depends on the
semantic properties of salient objects. By taking this into
account, authors developed a saliency model using
convolution network where inputs are given as raw images
and output is obtained in the form of saliency map.
Confidence relationship model [22] used to detect the object
from moving object detection technique. When dealing with
the salient object that contains several regions with different
appearances, salient object detection can be a difficult task.

Often only parts of the salient object are highlighted and
consistency between the salient regions is poor. This study
tackles this problem by introducing object to assist the salient
object detection. Rather than treating the object in the same
manner as other low-level cues (e.g. uniqueness, location etc.)
for the determination of regional saliency values, the authors
emphasise that object should also play a significant role in
tuning the consistency between salient regions.
The authors integrate object, uniqueness and centre bias to
find potential salient regions and then enforce consistency
between these regions using a full-connected Gaussian
Markov random field with the weights determined by the
object score [23]. In this field of learning based object
detection, [24] a new approach and experimented on PASCAL
VOC dataset. These methods are complex to implement and
uses both low-level and high-level feature to produce higherlevel feature vector.
Finally, this method is combined with region proposals and
the proposed method is described as R-CNN. The key
contribution of this work is denoted by its computation speed,
hence it is known as the Fast R-CNN technique for object
detection.

PROPOSED
OBJECT
RECOGNITION
DETECTION TECHNIQUES

AND

R-CNN is an object detection framework based on deep
convolutional networks, which includes a Region Proposal
Network (RPN) and an Object Detection Network. Both
networks are trained for sharing convolutional layers for fast
testing. In this work, we have combined shape feature
extraction with the existing model of feature extraction. This
combination of features improves detection and classification
accuracy. This model is tested with publically available
dataset VOC 2007 which contains various categories of
objects. Our main aim is to detect each category in the image
even occlusion are present in the image.
Multi task loss for R-CNN
L(p,u,tu,v) = Lcls(p,u)+ λ[ u >= 1 ] Lloc (tu,v)
𝑢 is the ground-truth class
𝑣 is ground-truth bounding-box regression target
Where

Lcls(p, u)=-log pu is the log loss for true class 𝑢

For Feature Extraction, Deep Neural Network is implemented,
this technique based on Krizhevsky's (Image Net Classification
with Deep Convolutional Neural Networks). In Caffe, Deep Neural
Networks contain eight learned layers – five convolutional and
three fully connected. When the system is complex sometimes it
gives random noise which has the undefined relation. It is called
over-fitting. To reduce that it uses ReLU and Dropout layers.
Following sequence shows the sequence of layers used and how
image passes through each layer.
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Input Image→ First Layer [ Conv Layer → Maxpooling ]→ Second Layer [ Conv Layer→ Maxpooling] → Third
Layer [Conv Layer] →Forth Layer[ Conv Layer ]→Fifth Layer[ Conv Layer → Maxpooling ]→ Six Layer [FC
Layer] → Seventh Layer [FC Layer] → Eight Layer [FC Layer]

Figure 1. R-CNN Networks
Past research implementations have that multi-scale
representation and it’s providing the effective combination in
much recent deep learning assignment. The sequence of the
experimental work of Region based Convolutional Neural
Network shown in figure-1.

boating, ground, hill, bike riding, animal, bus, and traffic.
R-CNN results when trained and tested using various region
proposal methods. These results use the ConvNet for Selective
Search (SS). From this result, proposed method (combined
shape feature extraction with the existing model of feature
extraction) gives good result in complex sceneries.

RESULT AND DISCUSSIONS
For the object recognition, final result images are obtained
from complex sceneries as shown in figure-2 like water,

Figure 2: final result of proposed technique
From the detection results shown in Table 1 two methods are
discussed and placed the comparison values for region-based
convolutional methods. The experimental results are
comparatively fulfilled for mostly in complex sceneries
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Table 1. Result of the comparison between PS1 and ES method
Method

Box

mAP

Aero

bike

bird

bottles

bus

car

cat

Chair

cow

ES1

300

7

68.5

74.1

77.2

67.7

53.9

51.0

75.1

79.2

78.9

PS

300

78.8

82.0

77.7

68.9

65.7

88.1

88.4

88.9

63.6

86.3

Method

table

dog

Horse

Mbike

person

plant

sheep

sofa

train

tv

ES1

50.7

78

61.1

79.1

71.4

72.2

75.9

62.5

77.4

66.4

PS

70.8

85.9

87.6

80.1

82.3

53.6

80.4

75.8

86.6

78.9
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CONCLUSION
Combined shape feature extraction with the existing model of
feature extraction technique provides better performance
when compared to existing deep convolution network
technique. According to this technique, various techniques are
using for improving the testing and training process, resulting,
and improvement in efficiency of the network.
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